Крымский форум (Crimea-Board) Поиск Участники Помощь Текстовая версия Crimea-Board.Net
Здравствуйте Гость .:: Вход :: Регистрация ::. .:: Выслать повторно письмо для активации  
 
> Рекламный блок.
 
 
 
 
 
> Ваша реклама, здесь
 
 
 

  Start new topic Start Poll 

> нет звука в линуксе, ubuntu 7.10 C-Media Electronics Inc CM8738 (rev 10)
svip | Профиль
Дата 23 Января, 2008, 23:29
Quote Post




Group Icon

Группа: Gold Member
Сообщений: 1493
Регистрация: 30.11.06
Авторитет: 13
Вне форума

Предупреждения:
(0%) -----


Добрый вечер уважаемые формчане. Помогите поднят звук в Ubuntu 7.10
Стоит встроенная звуковуха:
02:09.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Звука нет вообще.
Пляски с alsa толку не дали. ставил последнии .15 дрова. дрова стали но alsa-utils компилироваться не захотел.
alsaconf - не находит. в миксере выставил все на максимум.

Уже не знаю что дальше делать. Помогите решить проблему


____________________
Двое всегда договорятся, если хотя бы один из них – не дурак.
PMEmail Poster
68/5345   
Бобер | Бездомный
Реклама двигатель прогресса       
Quote Post



А кому сча лехко?
Group Icon


















_________________
Желающим разместить рекламу смотреть сюдой
/   
SlavaD | Профиль
Дата 23 Января, 2008, 23:37
Quote Post



Тех. Админ
Group Icon

Группа: Admin
Сообщений: 503
Регистрация: 13.08.03
Авторитет: 14
Вне форума



что говорит на нее
lspci -vvv
PMEmail Poster
1/7177   
svip | Профиль
Дата 23 Января, 2008, 23:43
Quote Post




Group Icon

Группа: Gold Member
Сообщений: 1493
Регистрация: 30.11.06
Авторитет: 13
Вне форума

Предупреждения:
(0%) -----


вот что говорит для звука, но я честно говоря мало что понял из этой инфы
Код

02:09.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
       Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
       Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Step                                                                             ping- SERR- FastB2B-
       Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort                                                                             - <MAbort- >SERR- <PERR-
       Interrupt: pin A routed to IRQ 5
       Region 0: I/O ports at c800 [size=256]
       Capabilities: [c0] Power Management version 2
               Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot                                                                             -,D3cold-)
               Status: D0 PME-Enable- DSel=0 DScale=0 PME-


Отредактировал svip - 23 Января, 2008, 23:44


____________________
Двое всегда договорятся, если хотя бы один из них – не дурак.
PMEmail Poster
34/5345   
SlavaD | Профиль
Дата 24 Января, 2008, 0:08
Quote Post



Тех. Админ
Group Icon

Группа: Admin
Сообщений: 503
Регистрация: 13.08.03
Авторитет: 14
Вне форума



странно, должна работать
попробуй aumix для регулировки
PMEmail Poster
14/7177   
svip | Профиль
Дата 24 Января, 2008, 0:16
Quote Post




Group Icon

Группа: Gold Member
Сообщений: 1493
Регистрация: 30.11.06
Авторитет: 13
Вне форума

Предупреждения:
(0%) -----


вот заметил при воспроизведении филма в mplayer говорит:
Код
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
alsa-lib: conf.c:3982:(snd_config_expand) Evaluate error: No such device
alsa-lib: pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM default
alsa-init: playback open error: No such device
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such file or directory
alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
alsa-lib: conf.c:3982:(snd_config_expand) Evaluate error: No such device
alsa-lib: pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM default
alsa-init: playback open error: No such device
[AO ARTS] loading the aRts backend "/usr/lib/libartscbackend.la" failed
[AO ESD] esd_open_sound failed: No such file or directory
AO: [pulse] Failed to connect to server: Connection refused
ao_nas: init(): Can't open nas audio server -> nosound
[AO SDL] Samplerate: 48000Hz Channels: Stereo Format s16le
alsa-lib: confmisc.c:768:(parse_card) cannot find card '0'
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
alsa-lib: confmisc.c:392:(snd_func_concat) error evaluating strings
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
alsa-lib: confmisc.c:1251:(snd_func_refer) error evaluating name
alsa-lib: conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
alsa-lib: conf.c:3982:(snd_config_expand) Evaluate error: No such device
alsa-lib: pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM default
[AO SDL] Unable to open audio: No available audio device
Opening /dev/dvb/adapter0/audio0
DVB AUDIO DEVICE: No such file or directory
AO: [null] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...


Походу не может найти звуковуху. а alsaconf нет. не знаю как настроить блин sad.gif
aumix установил. при запуске пишет:
aumix: ошибка открытия MIXER

Отредактировал svip - 24 Января, 2008, 0:19


____________________
Двое всегда договорятся, если хотя бы один из них – не дурак.
PMEmail Poster
93/5345   
alexk | Профиль
Дата 24 Января, 2008, 15:49
Quote Post



Отъявленный самурай
Group Icon

Группа: Старожил
Сообщений: 2676
Регистрация: 10.02.04
Авторитет: 5
Вне форума

Предупреждения:
(0%) -----


А модуль ядра загружен для нее?
dmesg|grep CMI8738 есть вывод?

Попробуй вручную загрузить необходимые модули:
sudo modprobe snd-cmipci;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss
(взято вот здесь: http://ubuntu-utah.ubuntuforums.org/showth...d.php?t=268908)


____________________
If you're determined to reinvent the wheel, at least try to invent a better one - Larry Wall
PMEmail Poster
40/13986   
svip | Профиль
Дата 24 Января, 2008, 16:49
Quote Post




Group Icon

Группа: Gold Member
Сообщений: 1493
Регистрация: 30.11.06
Авторитет: 13
Вне форума

Предупреждения:
(0%) -----


проблема оказалась в том что в alsamixer нужно было в разделе "Line-in" выставить "Rear Out" (узнал об этом путем тыка)
Цитата
dmesg|grep CMI8738 есть вывод
ничего не вывела.


____________________
Двое всегда договорятся, если хотя бы один из них – не дурак.
PMEmail Poster
41/5345   

Topic Options Start new topic Start Poll 

 



[ Script Execution time: 0.0676 ]   [ 12 queries used ]   [ GZIP включён ]


Создание и продвижение сайтов в Крыму



Top